找回密码
 注册

QQ登录

只需一步,快速开始

查看: 3724|回复: 9

请问为什么网站在搜索蜘蛛、机器人模拟工具中抓取的都是乱码??

[复制链接]
发表于 2011-7-22 17:37:50 | 显示全部楼层 |阅读模式
zzaaa.jpg
请问为什么网站在搜索蜘蛛、机器人模拟工具中抓取的都是乱码??
初步怀疑是我的编码问题.
但是我试过其他的网站,编码也是UTF-8的.但不会出现这种情况.
请解救!!!各路大侠来帮帮忙!

[[i] 本帖最后由 sky4089 于 2011-7-22 17:40 编辑 ]
发表于 2011-7-22 18:30:19 | 显示全部楼层
HTTP/1.0 200 OK
Date: Fri, 22 Jul 2011 10:26:49 GMT
Server: Apache/2.2.17 (Unix) mod_ssl/2.2.17 OpenSSL/1.0.0 mod_jk/1.2.31 PHP/5.2.17
Last-Modified: Fri, 22 Jul 2011 09:45:04 GMT
ETag: "2ce4b-7f47-4a8a551e6e800"
Accept-Ranges: bytes
Content-Length: 32583
Content-Type: text/html; charset=none
Content-Language: zh-cn
Connection: keep-alive

猜测可能跟这个有关,上面的这段文字是请求你的网站的时候,你的服务器响应的头部信息.
在里面输出的charset=none,可能是让那个 "站长工具" 读取到这个none,然后拿这个来解码了,
从而导致你在"站长工具"的这个页面中看到的是乱码,但你打开的不是乱码.
回复 支持 反对

使用道具 举报

 楼主| 发表于 2011-7-23 10:46:23 | 显示全部楼层

回复 2# faeng220 的帖子

谢谢faeng220.
请问,你上面的那段英文是从哪里看的?
我在"站长工具"你看到的是乱码,但是打开的不是乱码.
这应该会影响到搜索引擎对我的网站的收录吧?
这应该怎么解决?
回复 支持 反对

使用道具 举报

发表于 2011-7-23 11:27:31 | 显示全部楼层

答案

可能是你的网站服务器不稳定,或者你网站的代码编写不规则
回复 支持 反对

使用道具 举报

发表于 2011-7-23 15:39:40 | 显示全部楼层
站长工具上面的东西只是说了模拟,是他们自己简单实现的一个模拟的功能,
搜索引擎没那么白痴会分不清charset=none是不是正确的编码.
回复 支持 反对

使用道具 举报

发表于 2011-7-25 08:39:16 | 显示全部楼层
站长工具的问题造成的
回复 支持 反对

使用道具 举报

发表于 2011-7-25 09:09:12 | 显示全部楼层

回复 3# sky4089 [楼主] 的帖子

你所用的站长工具上就有这一项:
http://tool.chinaz.com/pagestatus/
  
http状态.jpg
回复 支持 反对

使用道具 举报

发表于 2011-7-25 12:46:15 | 显示全部楼层
有的站长工具不支持中文~ 无奈~
回复 支持 反对

使用道具 举报

发表于 2011-7-26 11:46:36 | 显示全部楼层
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>无标题文档</title>
</head>
回复 支持 反对

使用道具 举报

 楼主| 发表于 2011-7-26 15:50:10 | 显示全部楼层
谢谢各位.问题已经解决.我把首页的编码改为gb2312.结果就行了.
但是我还是不明白.为什么我的站用utf-8会不行.
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|Archiver|手机版|blueidea.com ( 湘ICP备12001430号 )

GMT+8, 2021-1-16 11:22 , Processed in 0.067077 second(s), 12 queries , Gzip On, Memcache On.

Powered by Discuz! X3.2 Licensed

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表